<!DOCTYPE html>
<html lang="en-US">
<head><script data-no-optimize="1">var litespeed_docref=sessionStorage.getItem("litespeed_docref");litespeed_docref&&(Object.defineProperty(document,"referrer",{get:function(){return litespeed_docref}}),sessionStorage.removeItem("litespeed_docref"));</script>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="pingback" href="https://eastgreenwichnews.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://eastgreenwichnews.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->
<script type="text/javascript" src="data:text/javascript;base64,ZG9jdW1lbnQuZG9jdW1lbnRFbGVtZW50LmNsYXNzTmFtZT0nanMn" defer></script>
<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin /><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>Police Log: Catalytic Converters, &#039;Disrespectful&#039; Straws &ndash; East Greenwich News</title>
<link rel="canonical" href="https://eastgreenwichnews.com/police-log-catalytic-converters-disrespectful-straws/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Police Log: Catalytic Converters, &#039;Disrespectful&#039; Straws &ndash; East Greenwich News" />
<meta property="og:description" content="Monday, March 7 1:08 p.m. – Police cited a Cranston man for driving with a suspended registration and suspended inspection after he was stopped on Division Street because one of his brake lights was out. He said he hadn’t renewed his registration because he hadn’t been able to get his car inspected. Police warned him [&hellip;]" />
<meta property="og:url" content="https://eastgreenwichnews.com/police-log-catalytic-converters-disrespectful-straws/" />
<meta property="og:site_name" content="East Greenwich News" />
<meta property="article:publisher" content="https://www.facebook.com/eastgreenwichnews" />
<meta property="article:published_time" content="2022-03-21T01:59:38+00:00" />
<meta property="og:image" content="https://eastgreenwichnews.com/wp-content/uploads/2014/10/eg-police-car-side.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="436" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@egreenwichnews" />
<meta name="twitter:site" content="@egreenwichnews" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://eastgreenwichnews.com/#organization","name":"East Greenwich News","url":"https://eastgreenwichnews.com/","sameAs":["https://www.facebook.com/eastgreenwichnews","https://www.linkedin.com/company/eastgreenwichnews/","https://www.youtube.com/user/EastGreenwichNews","https://twitter.com/egreenwichnews"],"logo":{"@type":"ImageObject","@id":"https://eastgreenwichnews.com/#logo","inLanguage":"en-US","url":"https://eastgreenwichnews.com/wp-content/uploads/2014/07/header-logo.jpg","contentUrl":"https://eastgreenwichnews.com/wp-content/uploads/2014/07/header-logo.jpg","width":287,"height":90,"caption":"East Greenwich News"},"image":{"@id":"https://eastgreenwichnews.com/#logo"}},{"@type":"WebSite","@id":"https://eastgreenwichnews.com/#website","url":"https://eastgreenwichnews.com/","name":"East Greenwich News","description":"News and information for the 02818 community","publisher":{"@id":"https://eastgreenwichnews.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://eastgreenwichnews.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://eastgreenwichnews.com/police-log-catalytic-converters-disrespectful-straws/#primaryimage","inLanguage":"en-US","url":"https://eastgreenwichnews.com/wp-content/uploads/2014/10/eg-police-car-side.jpg","contentUrl":"https://eastgreenwichnews.com/wp-content/uploads/2014/10/eg-police-car-side.jpg","width":640,"height":436},{"@type":"WebPage","@id":"https://eastgreenwichnews.com/police-log-catalytic-converters-disrespectful-straws/#webpage","url":"https://eastgreenwichnews.com/police-log-catalytic-converters-disrespectful-straws/","name":"Police Log: Catalytic Converters, 'Disrespectful' Straws &ndash; East Greenwich News","isPartOf":{"@id":"https://eastgreenwichnews.com/#website"},"primaryImageOfPage":{"@id":"https://eastgreenwichnews.com/police-log-catalytic-converters-disrespectful-straws/#primaryimage"},"datePublished":"2022-03-21T01:59:38+00:00","dateModified":"2022-03-21T01:59:38+00:00","breadcrumb":{"@id":"https://eastgreenwichnews.com/police-log-catalytic-converters-disrespectful-straws/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://eastgreenwichnews.com/police-log-catalytic-converters-disrespectful-straws/"]}]},{"@type":"BreadcrumbList","@id":"https://eastgreenwichnews.com/police-log-catalytic-converters-disrespectful-straws/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://eastgreenwichnews.com/"},{"@type":"ListItem","position":2,"name":"Police Log: Catalytic Converters, &#8216;Disrespectful&#8217; Straws"}]},{"@type":"NewsArticle","@id":"https://eastgreenwichnews.com/police-log-catalytic-converters-disrespectful-straws/#article","isPartOf":{"@id":"https://eastgreenwichnews.com/police-log-catalytic-converters-disrespectful-straws/#webpage"},"author":{"@id":"https://eastgreenwichnews.com/#/schema/person/dc4b87d33f6216765236e5423ea1fe1e"},"headline":"Police Log: Catalytic Converters, &#8216;Disrespectful&#8217; Straws","datePublished":"2022-03-21T01:59:38+00:00","dateModified":"2022-03-21T01:59:38+00:00","mainEntityOfPage":{"@id":"https://eastgreenwichnews.com/police-log-catalytic-converters-disrespectful-straws/#webpage"},"wordCount":1152,"commentCount":0,"publisher":{"@id":"https://eastgreenwichnews.com/#organization"},"image":{"@id":"https://eastgreenwichnews.com/police-log-catalytic-converters-disrespectful-straws/#primaryimage"},"thumbnailUrl":"https://eastgreenwichnews.com/wp-content/uploads/2014/10/eg-police-car-side.jpg","keywords":["blotter","EGPD","log","Police"],"articleSection":["Police &amp; Fire"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://eastgreenwichnews.com/police-log-catalytic-converters-disrespectful-straws/#respond"]}]},{"@type":"Person","@id":"https://eastgreenwichnews.com/#/schema/person/dc4b87d33f6216765236e5423ea1fe1e","name":"Elizabeth McNamara","image":{"@type":"ImageObject","@id":"https://eastgreenwichnews.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/dd6540ec77df358cedbe107546bf7b68?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/dd6540ec77df358cedbe107546bf7b68?s=96&d=mm&r=g","caption":"Elizabeth McNamara"},"url":"https://eastgreenwichnews.com/author/elizabethfmcnamara/"}]}</script>

<script type='application/javascript'>console.log('PixelYourSite Free version 8.2.17');</script>
<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//unicons.iconscout.com' />
<link rel='dns-prefetch' href='//www.youtube.com' />
<link rel="alternate" type="application/rss+xml" title="East Greenwich News &raquo; Feed" href="https://eastgreenwichnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="East Greenwich News &raquo; Comments Feed" href="https://eastgreenwichnews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="East Greenwich News &raquo; Police Log: Catalytic Converters, &#8216;Disrespectful&#8217; Straws Comments Feed" href="https://eastgreenwichnews.com/police-log-catalytic-converters-disrespectful-straws/feed/" />
<meta content="Extra v.4.15.0" name="generator" /><link rel='stylesheet' id='wp-block-library-css' href='https://eastgreenwichnews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://eastgreenwichnews.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://eastgreenwichnews.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.9.2' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='directorist-openstreet-map-leaflet-css' href='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-css/openstreet-map/leaflet.css?ver=7.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='directorist-openstreet-map-openstreet-css' href='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-css/openstreet-map/openstreet.css?ver=7.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='directorist-select2-css' href='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-css/select2.min.css?ver=7.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='directorist-unicons-css' href='//unicons.iconscout.com/release/v3.0.3/css/line.css?ver=7.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='directorist-font-awesome-css' href='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-css/font-awesome.min.css?ver=7.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='directorist-line-awesome-css' href='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-css/line-awesome.min.css?ver=7.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='directorist-ez-media-uploader-css' href='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-css/ez-media-uploader.css?ver=7.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='directorist-sweetalert-css' href='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-css/sweetalert.min.css?ver=7.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='directorist-main-style-css' href='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/css/public-main.min.css?ver=7.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='directorist-inline-style-css' href='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/other/inline-style.css?ver=7.1.2' type='text/css' media='all' />
<style id='directorist-inline-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='directorist-settings-style-css' href='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/other/settings-style.css?ver=7.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='give-styles-css' href='https://eastgreenwichnews.com/wp-content/plugins/give/assets/dist/css/give.css?ver=2.19.5' type='text/css' media='all' />
<link rel='stylesheet' id='give-donation-summary-style-frontend-css' href='https://eastgreenwichnews.com/wp-content/plugins/give/assets/dist/css/give-donation-summary.css?ver=2.19.5' type='text/css' media='all' />
<link rel='stylesheet' id='mc4wp-form-themes-css' href='https://eastgreenwichnews.com/wp-content/plugins/mailchimp-for-wp/assets/css/form-themes.css?ver=4.8.7' type='text/css' media='all' />
<style id='extra-style-inline-inline-css' type='text/css'>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</style>
<style id='extra-dynamic-critical-inline-css' type='text/css'>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</style>
<link rel='preload' id='extra-dynamic-css' href='https://eastgreenwichnews.com/wp-content/et-cache/34121/et-extra-dynamic-tb-22272-tb-21502-34121.css?ver=1647828004' as='style' media='all' onload="this.onload=null;this.rel='stylesheet'" />
<link rel='stylesheet' id='__EPYT__style-css' href='https://eastgreenwichnews.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=14.1' type='text/css' media='all' />
<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 50%;
                }
                
                         @media (min-width:0px) and (max-width: 767px) {
                            .epyt-gallery-rowbreak {
                                display: none;
                            }
                            .epyt-gallery-allthumbs[class*="epyt-cols"] .epyt-gallery-thumb {
                                width: 100% !important;
                            }
                          }
</style>
<link rel='stylesheet' id='jetpack_css-css' href='https://eastgreenwichnews.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.7' type='text/css' media='all' />
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?v=1.43.8&#038;ver=5.9.2' id='broadstreet-cdn-js'></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js' defer data-deferred="1"></script>
<script type='text/javascript' id='give-js-extra' src="data:text/javascript;base64,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" defer></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/give/assets/dist/js/give.js?ver=2.19.5' id='give-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/pixelyoursite/dist/scripts/jquery.bind-first-0.2.3.min.js?ver=5.9.2' id='jquery-bind-first-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/pixelyoursite/dist/scripts/js.cookie-2.1.3.min.js?ver=2.1.3' id='js-cookie-js' defer data-deferred="1"></script>
<script type='text/javascript' id='pys-js-extra' src="data:text/javascript;base64,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" defer></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/pixelyoursite/dist/scripts/public.js?ver=8.2.17' id='pys-js' defer data-deferred="1"></script>

<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-54613721-1' id='google_gtagjs-js' defer data-deferred="1"></script>
<script type='text/javascript' id='google_gtagjs-js-after' src="data:text/javascript;base64,d2luZG93LmRhdGFMYXllcj13aW5kb3cuZGF0YUxheWVyfHxbXTtmdW5jdGlvbiBndGFnKCl7ZGF0YUxheWVyLnB1c2goYXJndW1lbnRzKX0KZ3RhZygnc2V0JywnbGlua2VyJyx7ImRvbWFpbnMiOlsiZWFzdGdyZWVud2ljaG5ld3MuY29tIl19KTtndGFnKCJqcyIsbmV3IERhdGUoKSk7Z3RhZygic2V0IiwiZGV2ZWxvcGVyX2lkLmRaVE5pTVQiLCEwKTtndGFnKCJjb25maWciLCJVQS01NDYxMzcyMS0xIix7ImFub255bWl6ZV9pcCI6ITB9KTtndGFnKCJjb25maWciLCJHLTJKNEdISjhTS00iKQ==" defer></script>

<script type='text/javascript' id='__ytprefs__-js-extra' src="data:text/javascript;base64,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" defer></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=14.1' id='__ytprefs__-js' defer data-deferred="1"></script>
<link rel="https://api.w.org/" href="https://eastgreenwichnews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://eastgreenwichnews.com/wp-json/wp/v2/posts/34121" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://eastgreenwichnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://eastgreenwichnews.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.9.2" />
<link rel='shortlink' href='https://eastgreenwichnews.com/?p=34121' />
<link rel="alternate" type="application/json+oembed" href="https://eastgreenwichnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Feastgreenwichnews.com%2Fpolice-log-catalytic-converters-disrespectful-straws%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://eastgreenwichnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Feastgreenwichnews.com%2Fpolice-log-catalytic-converters-disrespectful-straws%2F&#038;format=xml" />
<meta name="description" content="Monday, March 7 1:08 p.m. – Police cited a Cranston man for driving with a suspended registration and suspended inspection after he was stopped on Division Street because one of his brake lights was..." />
<meta name="generator" content="Site Kit by Google 1.70.0" /><meta name="generator" content="Give v2.19.5" />
<style type='text/css'>img#wpstats{display:none}</style>
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /><script src="data:text/javascript;base64,alF1ZXJ5KGZ1bmN0aW9uKCQpeyQoJyNmb290ZXItaW5mbycpLmh0bWwoJyZjb3B5OyAnKyhuZXcgRGF0ZSkuZ2V0RnVsbFllYXIoKSsnIEVhc3QgR3JlZW53aWNoIE5ld3MuIEFsbCByaWdodHMgcmVzZXJ2ZWQuJyl9KQ==" defer></script>
<script src="data:text/javascript;base64,alF1ZXJ5KGRvY3VtZW50KS5yZWFkeShmdW5jdGlvbigkKXskKCdpbWdbc3JjKj0iZGVmYXVsdC1saXN0aW5nLWltYWdlLmpwZyJdJykucGFyZW50cygnLmRpcmVjdG9yaXN0LWxpc3Rpbmctc2luZ2xlX190aHVtYicpLmhpZGUoKTskKCdpbWdbc3JjKj0ic3BhY2VyLmpwZyJdJykucGFyZW50cygnLmRpcmVjdG9yaXN0LWxpc3Rpbmctc2luZ2xlX190aHVtYicpLmhpZGUoKTskKCcuZGlyZWN0b3Jpc3QtZm9ybS1lbGVtZW50JykucGFyZW50cygnLmRpcmVjdG9yaXN0LWFkdmFuY2VkLWZpbHRlcl9fYmFzaWMtLWVsZW1lbnQnKS5oaWRlKCk7JCgnaW1nW3NyYyo9InNwYWNlci5qcGciXScpLnBhcmVudHMoJy5hdGJkX2xpc3RpbmdfdGh1bWJuYWlsX2FyZWEnKS5oaWRlKCl9KQ==" defer></script>
<script src="data:text/javascript;base64,alF1ZXJ5KGZ1bmN0aW9uKCQpeyQoIi5jb3ZpZDE5IGgxIikucmVwbGFjZVdpdGgoIjxoMT48YSBocmVmPSdodHRwczovL2Vhc3RncmVlbndpY2huZXdzLmNvbS9jYXRlZ29yeS9jb3ZpZC0xOS8nPmNvdmlkLTE5PC9hPjwvaDE+Iik7JCgiLnJlYWwtZXN0YXRlIGgxIikucmVwbGFjZVdpdGgoIjxoMT48YSBocmVmPSdodHRwczovL2Vhc3RncmVlbndpY2huZXdzLmNvbS9jYXRlZ29yeS9yZWFsLWVzdGF0ZS0yLyc+UmVhbCBFc3RhdGU8L2E+PC9oMT4iKTskKCIucG9saWNlIGgxIikucmVwbGFjZVdpdGgoIjxoMT48YSBocmVmPSdodHRwczovL2Vhc3RncmVlbndpY2huZXdzLmNvbS9jYXRlZ29yeS9wb2xpY2UtZmlyZS8nPlBvbGljZSAmYW1wOyBGaXJlPC9hPjwvaDE+Iik7JCgiLm9iaXR1YXJpZXMgaDEiKS5yZXBsYWNlV2l0aCgiPGgxPjxhIGhyZWY9J2h0dHBzOi8vZWFzdGdyZWVud2ljaG5ld3MuY29tL2NhdGVnb3J5L29iaXR1YXJpZXMvJz5PYml0dWFyaWVzPC9hPjwvaDE+Iik7JCgiLmVnZWF0cyBoMSIpLnJlcGxhY2VXaXRoKCI8aDE+PGEgaHJlZj0naHR0cHM6Ly9lYXN0Z3JlZW53aWNobmV3cy5jb20vY2F0ZWdvcnkvZWctZWF0cy8nPkVHIEVhdHM8L2E+PC9oMT4iKX0p" defer></script><link rel="icon" href="https://eastgreenwichnews.com/wp-content/uploads/2020/08/EG-News-fav.png" sizes="32x32" />
<link rel="icon" href="https://eastgreenwichnews.com/wp-content/uploads/2020/08/EG-News-fav.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://eastgreenwichnews.com/wp-content/uploads/2020/08/EG-News-fav.png" />
<meta name="msapplication-TileImage" content="https://eastgreenwichnews.com/wp-content/uploads/2020/08/EG-News-fav.png" />
<link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://eastgreenwichnews.com/wp-content/et-cache/global/et-extra-customizer-global.min.css?ver=1647614440" /><script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body class="post-template-default single single-post postid-34121 single-format-standard et-tb-has-template et-tb-has-body et-tb-has-footer et_extra et_fullwidth_nav et_fullwidth_secondary_nav et_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db directorist-content-active directorist-preload">
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div id="page-container" class="page-container">
<div id="et-boc" class="et-boc">

<header class="header left-right">

<div id="top-header" style="">
<div class="container">

<div id="et-secondary-nav" class="">
<ul id="et-secondary-menu" class="nav"><li class="datelink menu-item menu-item-type-custom menu-item-object-custom menu-item-21730"><a href="#"><p><span id="datetime"></span></p> <script src="data:text/javascript;base64,dmFyIGR0PW5ldyBEYXRlKCk7ZG9jdW1lbnQuZ2V0RWxlbWVudEJ5SWQoImRhdGV0aW1lIikuaW5uZXJIVE1MPWR0LnRvTG9jYWxlRGF0ZVN0cmluZygp" defer></script> EAST GREENWICH, RI</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21703"><a href="https://eastgreenwichnews.com/become-a-sponsor/">BECOME A SPONSOR</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33663"><a href="https://eastgreenwichnews.com/donate/">DONATE</a></li>
</ul> </div>

<div id="et-info">

<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://www.facebook.com/eastgreenwichnews/" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/egreenwichnews" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon instagram">
<a href="https://www.instagram.com/eastgreenwichnews/" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a>
</li>
<li class="et-extra-social-icon youtube">
<a href="https://www.youtube.com/user/EastGreenwichNews" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-youtube"></a>
</li>
</ul>

<div class="et-top-search" style="">
<form role="search" class="et-search-form" method="get" action="https://eastgreenwichnews.com/">
<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" />
<button class="et-search-submit"></button>
</form> </div>

</div>
</div>
</div>

<div id="main-header-wrapper">
<div id="main-header" data-fixed-height="110">
<div class="container">


<a class="logo" href="https://eastgreenwichnews.com/" data-fixed-height="60">
<img src="https://eastgreenwichnews.com/wp-content/uploads/2020/09/EGNews_Logo_Final.png" alt="East Greenwich News" id="logo" />
</a>

<div id="et-navigation" class="">
<ul id="et-menu" class="nav"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24139"><a href="https://eastgreenwichnews.com/latest-news/">Latest News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21738"><a href="https://eastgreenwichnews.com/category/covid-19/">COVID-19</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-21583"><a href="#">Town</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21736"><a href="https://eastgreenwichnews.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10699"><a href="https://eastgreenwichnews.com/category/government/">Government</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-10701"><a href="https://eastgreenwichnews.com/category/police-fire/">Police &amp; Fire</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10698"><a href="https://eastgreenwichnews.com/category/business/">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14763"><a href="https://eastgreenwichnews.com/category/real-estate-2/">Real Estate</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23802"><a href="https://eastgreenwichnews.com/community-guide/">Community Guide</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-21584"><a href="#">Education</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10703"><a href="https://eastgreenwichnews.com/category/schools-2/">Schools</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17798"><a href="https://eastgreenwichnews.com/category/sports-2/">Sports</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-21585"><a href="#">General</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22708"><a href="https://eastgreenwichnews.com/category/general-interest/">General Interest</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11902"><a href="https://eastgreenwichnews.com/category/good-news/">Good News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-21587"><a href="#">Arts &#038; Events</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21550"><a href="https://eastgreenwichnews.com/category/arts/">Arts</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21559"><a href="https://eastgreenwichnews.com/category/entertainment/">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21561"><a href="https://eastgreenwichnews.com/category/features/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25832"><a href="https://eastgreenwichnews.com/category/eg-eats/">EG Eats</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22709"><a href="https://eastgreenwichnews.com/category/mems-rems-by-bruce/">Mems &amp; Rems by Bruce</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18214"><a href="https://eastgreenwichnews.com/category/obituaries/">Obituaries</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21574"><a href="https://eastgreenwichnews.com/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21549"><a href="https://eastgreenwichnews.com/category/announcements/">Announcements</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28947"><a href="https://eastgreenwichnews.com/category/jobs/">Now Hiring</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-21593"><a href="#">About</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21588"><a href="https://eastgreenwichnews.com/about-eg-news/">About EG News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21590"><a href="https://eastgreenwichnews.com/become-a-sponsor/">Become a Sponsor</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22354"><a href="https://eastgreenwichnews.com/donors-sponsors/">Donors &#038; Sponsors</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21592"><a href="https://eastgreenwichnews.com/donate/">Donate</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-27489"><a href="#">SHOP LOCAL</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23800"><a href="https://eastgreenwichnews.com/shop-local/">Business Directory</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27499"><a href="https://eastgreenwichnews.com/restaurant-guide/">Restaurant Guide</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33288"><a href="https://eastgreenwichnews.com/camp-guide/">Camp Guide</a></li>
</ul>
</li>
</ul> <div id="et-mobile-navigation">
<span class="show-menu">
<div class="show-menu-button">
<span></span>
<span></span>
<span></span>
</div>
<p>Select Page</p>
</span>
<nav>
</nav>
</div>  </div>
</div>
</div>
</div>
</header>
<div class="et-l et-l--body">
<div class="et_builder_inner_content et_pb_gutters3"><div class="et_pb_section et_pb_section_0_tb_body et_section_regular">
<div class="et_pb_row et_pb_row_0_tb_body">
<div class="et_pb_column et_pb_column_2_3 et_pb_column_0_tb_body  et_pb_css_mix_blend_mode_passthrough">
<div class="et_pb_module et_pb_post_title et_pb_post_title_0_tb_body et_pb_bg_layout_light  et_pb_text_align_left">
<div class="et_pb_title_container">
<h1 class="entry-title">Police Log: Catalytic Converters, &#8216;Disrespectful&#8217; Straws</h1><p class="et_pb_title_meta_container"> by <span class="author vcard"><a href="https://eastgreenwichnews.com/author/elizabethfmcnamara/" title="Posts by Elizabeth McNamara" rel="author">Elizabeth McNamara</a></span> | <span class="published">Mar 20, 2022</span></p>
</div>
<div class="et_pb_title_featured_container"><span class="et_pb_image_wrap"><img loading="lazy" width="640" height="436" src="https://eastgreenwichnews.com/wp-content/uploads/2014/10/eg-police-car-side.jpg" alt="" title="eg police car side view / log" srcset="https://eastgreenwichnews.com/wp-content/uploads/2014/10/eg-police-car-side.jpg 640w, https://eastgreenwichnews.com/wp-content/uploads/2014/10/eg-police-car-side-300x204.jpg 300w" sizes="(max-width: 640px) 100vw, 640px" class="wp-image-6836" /></span></div>
</div><div class="et_pb_module et_pb_post_content et_pb_post_content_0_tb_body">
<p><b>Monday, March 7</b></p>
<p><b>1:08 p.m.</b><span style="font-weight: 400;"> – Police cited a Cranston man for driving with a suspended registration and suspended inspection after he was stopped on Division Street because one of his brake lights was out. He said he hadn’t renewed his registration because he hadn’t been able to get his car inspected. Police warned him about the brake light and had the car towed.</span></p>
<p><b>10:04 p.m. </b><span style="font-weight: 400;">– Police cited an East Greenwich man, 18, for possessing marijuana after he was pulled over for going 45 mph on Middle Road, a 25 mph zone. The car smelled of marijuana so police asked the driver about it. He said he had smoked pot earlier in the evening; he handed over a small bag of pot to police (less than an ounce). Police said they did not see signs of impairment so they warned him about speeding and said they would be sending him a citation for the marijuana possession.</span></p>
<p><b>Tuesday, March 8</b></p>
<p><b>12:35 a.m.</b><span style="font-weight: 400;"> – A caller told police about loud beeping on Somerset Street. Police found a beeping smoke detector in a dumpster and disabled it.</span></p>
<p><b>8:37 p.m.</b><span style="font-weight: 400;"> – Police put down a deer that had been critically injured by a car on Middle Road. Police alerted DEM. </span></p>
<p><b>Wednesday, March 9</b></p>
<p><b>1:28 a.m. </b><span style="font-weight: 400;">– Police cited a Massachusetts man for driving a car with suspended registration after he was stopped for speeding on Division Street. During routine checks, the registration came back as belonging to another car; the registration for the actual car – checked against the car’s VIN number – came back as suspended. Police had the car towed and gave the man the suspended license citation and a speeding ticket.</span></p>
<p><b>1:56 p.m.</b><span style="font-weight: 400;"> –  A South Kingstown man told police it appeared someone had tampered with his catalytic converter while he was parked at his job, on South County Trail. His truck sounded louder after work and his mechanic notice markings around the catalytic converter when he took the car in a day later. There were no security cameras aimed at the parking lot where he worked. </span></p>
<p><b>5:08 p.m.</b><span style="font-weight: 400;"> – An EG man told police he was missing some things, mainly tools, after being out of his house during renovations for several months in 2021. The contractor said his team did not take them. </span></p>
<p><b>11:47 p.m.</b><span style="font-weight: 400;"> – Police cited a Coventry man for driving with a suspended registration after police noticed him driving 15 miles over the speed limit on Division Road and making a right turn without signaling. Police had the car towed.</span></p>
<p><b>Thursday, March 10</b></p>
<p><b>1:58 a.m.</b><span style="font-weight: 400;"> – Police and fire responded to an overdose; the youth was transported to Hasbro. </span></p>
<p><b>6:18 p.m. </b><span style="font-weight: 400;">– An EG woman told police someone tried to defraud her via computer. She said while using her computer, a popup appeared saying she had been hacked and to call the “Microsoft” number on the screen. She called the number and was told all of her bank accounts had been hacked, a $5,800 charge had been made and she needed to make a duplicate payment at a Walmart. The caller said the woman only had 2 and a half hours to make the payment and to keep it secret. Suspicious, she called the police.</span></p>
<p><b>6:27 p.m.</b><span style="font-weight: 400;"> – A shopkeeper on Main Street complained about a man riding an electric bike up and down Main Street on the sidewalk for several hours straight, disturbing her customers and presenting a potential peril to walkers. Police could not locate the cyclist.</span></p>
<p><b>Friday, March 11</b></p>
<p><b>6:17 p.m.</b><span style="font-weight: 400;"> – A caller said there was a car parked on Foster Way that he doesn’t recognize and that someone was inside. Police found the car empty. Police reached the owner of the car who said her son was using it to visit a friend who lived nearby.</span></p>
<p><b>7:20 p.m. </b><span style="font-weight: 400;">– A Pennsylvania man in R.I. doing work for Electric Boat told police someone had taken the catalytic converter from his truck. He said had left his truck parked in the park-and-ride on South County Trail during the week, commuting to the job in another vehicle. When he returned to the truck today, the motor was really loud and he saw the converter was missing. The parking lot does not have security cameras.</span></p>
<p><b>9:27 p.m.</b><span style="font-weight: 400;"> – A bartender at Raku Sakura told police a customer hit him after the customer complained about the way the bartender had put straws down on the bar, saying it had been “disrespectful.” Police took the customer into custody but then released him after the bartender said he did not want to press charges, just wanted the man out.  </span></p>
<p><b>Saturday, March 12</b></p>
<p><b>12:54 a.m. </b><span style="font-weight: 400;">– Police arrested a Kingston man, 31, for driving while intoxicated after he was stopped on Post Road because his headlights were not on and he allegedly was driving 60 mph in a 35 mph zone. Police smelled alcohol on the man’s breath; he said he’d had a couple drinks at Low Key on Main Street and was heading home. He agreed to field sobriety tests, which he failed so police took him into custody. He refused to take a BAC chemical breath test at the station, so he was given a district court summons for the DUI and a traffic court citation for refusing the test, as well as a speeding ticket and a ticket because of the headlights.</span></p>
<p><b>1:15 a.m.</b><span style="font-weight: 400;"> – Police arrested a North Kingstown man, 27, for driving with a suspended license after he was pulled over on First Avenue for driving 40 mph in a 25 mph zone. Routine checks turned up the license suspension. Police gave the man a district court summons; the man’s father was in the car so he drove the car home.</span></p>
<p><b>Sunday, March 13</b></p>
<p><b>9:44 a.m.</b><span style="font-weight: 400;"> – Police arrested a North Kingstown man, 32, for driving with a suspended license after he was pulled over on South County Trail because his inspection sticker was expired and he had something hanging from his rearview mirror. Routine checks showed the car registration was suspended in 2020. The man said he’d been trying to remedy the registration issue and also told police his license was suspended, which police confirmed. Police gave him a district court summons and citations for failing to have valid insurance and for the registration problem. Police had the car towed.</span></p>
<p><b>5:09 p.m.</b><span style="font-weight: 400;"> – A caller told police about a man in camouflage clothing walking on South Road who appeared to be in need of assistance. Police spoke with the man, who was out getting his mail. </span></p>
<p><b>10:05 p.m.</b><span style="font-weight: 400;"> – Police arrest a North Kingstown woman, 20, for driving with a suspended license after she was pulled over on Davisville Road after making a dangerous turn from Frenchtown Road. The woman told police there “may be an issue” with her car registration. Checks showed both the woman’s license and registration were suspended. Police gave her a district court summons for the license (second offense), a citation for the registration and had the car towed. A family member came to give her a ride home.</span></p>
<div style='margin:5px auto; margin-bottom: 15px;' id='zone_load_1412382863'><broadstreet-zone callback="zone_load_1412382863" zone-id="70138" keywords="not_home_page,not_landing_page,is_article_page,police-fire,police-log-catalytic-converters-disrespectful-straws,post" soft-keywords="true"></broadstreet-zone></div><script src="data:text/javascript;base64,d2luZG93LnpvbmVfbG9hZF8xNDEyMzgyODYzPWZ1bmN0aW9uKHosZCl7aWYoIWQuY291bnQpZG9jdW1lbnQuZ2V0RWxlbWVudEJ5SWQoJ3pvbmVfbG9hZF8xNDEyMzgyODYzJykuc3R5bGUuZGlzcGxheT0nbm9uZSd9" defer></script>
</div><div class="et_pb_module et_pb_divider et_pb_divider_0_tb_body et_pb_divider_position_ et_pb_space"><div class="et_pb_divider_internal"></div></div><div class="et_pb_module et_pb_text et_pb_text_0_tb_body  et_pb_text_align_left et_pb_bg_layout_light">
<div class="et_pb_text_inner"><p><em><strong>Value the news you get here on East Greenwich News?</strong> As a 501-c3, we depend on reader support. Become a sustaining (monthly) donor or make a one-time donation! Click on the Donate button below or send a check to EG News, 18 Prospect St., East Greenwich, RI 02818. Thanks.</em></p></div>
</div><div class="et_pb_button_module_wrapper et_pb_button_0_tb_body_wrapper  et_pb_module ">
<a class="et_pb_button et_pb_button_0_tb_body et_pb_bg_layout_light" href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=RYEHTGQBSJEWW&#038;source=url" target="_blank">DONATE</a>
</div><div class="et_pb_module et_pb_divider et_pb_divider_1_tb_body et_pb_divider_position_ et_pb_space"><div class="et_pb_divider_internal"></div></div><div class="et_pb_module et_pb_comments_0_tb_body et_pb_comments_module et_pb_bg_layout_light et_pb_no_avatar">
<section id="comment-wrap">
<h1 id="comments" class="page_title">0 Comments</h1>
<div id="comment-section" class="nocomments">
</div>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span>Submit a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/police-log-catalytic-converters-disrespectful-straws/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://eastgreenwichnews.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">Comment <span class="required" aria-hidden="true">*</span></label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required" /></p>
<p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><button name="submit" type="submit" id="et_pb_submit" class="submit">Submit Comment</button> <input type='hidden' name='comment_post_ID' value='34121' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="ff878f2c62" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="216" /><script src="data:text/javascript;base64,ZG9jdW1lbnQuZ2V0RWxlbWVudEJ5SWQoImFrX2pzXzEiKS5zZXRBdHRyaWJ1dGUoInZhbHVlIiwobmV3IERhdGUoKSkuZ2V0VGltZSgpKQ==" defer></script></p></form> </div>
</section>
</div><div class="et_pb_module et_pb_divider et_pb_divider_2_tb_body et_pb_divider_position_ et_pb_space"><div class="et_pb_divider_internal"></div></div><div class="et_pb_module et_pb_text et_pb_text_1_tb_body  et_pb_text_align_left et_pb_bg_layout_light">
<div class="et_pb_text_inner"><h1><strong>RELATED STORIES</strong></h1></div>
</div><div class="et_pb_module et_pb_blog_0_tb_body et_pb_blog_grid_wrapper et_pb_bg_layout_light">
<div class="et_pb_blog_grid clearfix ">
<div class="et_pb_ajax_pagination_container">
<div class="et_pb_salvattore_content" data-columns>
<article id="post-34040" class="et_pb_post clearfix et_pb_blog_item_0_0 post-34040 post type-post status-publish format-standard has-post-thumbnail hentry category-police-fire tag-blotter tag-egpd tag-license tag-log tag-police et-has-post-format-content et_post_format-et-post-format-standard">
<div class="et_pb_image_container"><a href="https://eastgreenwichnews.com/police-log-so-many-suspended-licenses/" class="entry-featured-image-url"><img loading="lazy" src="https://eastgreenwichnews.com/wp-content/uploads/2014/12/egpd-car-1-400x250.jpg" alt="Police Log: So Many Suspended Licenses!" class="" srcset="https://eastgreenwichnews.com/wp-content/uploads/2014/12/egpd-car-1.jpg 479w, https://eastgreenwichnews.com/wp-content/uploads/2014/12/egpd-car-1-400x250.jpg 480w " sizes="(max-width:479px) 479px, 100vw " width="400" height="250" /></a></div>
<h2 class="entry-title"><a href="https://eastgreenwichnews.com/police-log-so-many-suspended-licenses/">Police Log: So Many Suspended Licenses!</a></h2>
<p class="post-meta"><span class="published">Mar 13, 2022</span></p><div class="post-content"><div class="post-content-inner"><p>Monday, Feb. 28 9 a.m. – An East Greenwich woman told police she had come across two men with a...</p>
</div></div>
</article>
<article id="post-34023" class="et_pb_post clearfix et_pb_blog_item_0_1 post-34023 post type-post status-publish format-standard has-post-thumbnail hentry category-government category-police-fire tag-bourget tag-egpd tag-insubordination tag-leobor tag-police et-has-post-format-content et_post_format-et-post-format-standard">
<div class="et_pb_image_container"><a href="https://eastgreenwichnews.com/town-fires-police-officer-over-vaccine-or-test-policy/" class="entry-featured-image-url"><img loading="lazy" src="https://eastgreenwichnews.com/wp-content/uploads/2014/08/eg-police-dept.-400x250.jpg" alt="Town Fires Police Officer Over Vaccine-or-Test Policy" class="" srcset="https://eastgreenwichnews.com/wp-content/uploads/2014/08/eg-police-dept..jpg 479w, https://eastgreenwichnews.com/wp-content/uploads/2014/08/eg-police-dept.-400x250.jpg 480w " sizes="(max-width:479px) 479px, 100vw " width="400" height="250" /></a></div>
<h2 class="entry-title"><a href="https://eastgreenwichnews.com/town-fires-police-officer-over-vaccine-or-test-policy/">Town Fires Police Officer Over Vaccine-or-Test Policy</a></h2>
<p class="post-meta"><span class="published">Mar 11, 2022</span></p><div class="post-content"><div class="post-content-inner"><p>Mark Bourget refused COVID vaccine or comply with weekly testing requirements Town Manager Andy...</p>
</div></div>
</article>
<article id="post-33954" class="et_pb_post clearfix et_pb_blog_item_0_2 post-33954 post type-post status-publish format-standard has-post-thumbnail hentry category-police-fire tag-animal-head tag-blotter tag-calfs-head tag-egpd tag-log tag-police et-has-post-format-content et_post_format-et-post-format-standard">
<div class="et_pb_image_container"><a href="https://eastgreenwichnews.com/police-log-grim-waterfront-discovery-talking-house/" class="entry-featured-image-url"><img loading="lazy" src="https://eastgreenwichnews.com/wp-content/uploads/2014/08/eg-police-dept.-400x250.jpg" alt="Police Log: Grim Waterfront Discovery, Talking House" class="" srcset="https://eastgreenwichnews.com/wp-content/uploads/2014/08/eg-police-dept..jpg 479w, https://eastgreenwichnews.com/wp-content/uploads/2014/08/eg-police-dept.-400x250.jpg 480w " sizes="(max-width:479px) 479px, 100vw " width="400" height="250" /></a></div>
<h2 class="entry-title"><a href="https://eastgreenwichnews.com/police-log-grim-waterfront-discovery-talking-house/">Police Log: Grim Waterfront Discovery, Talking House</a></h2>
<p class="post-meta"><span class="published">Mar 8, 2022</span></p><div class="post-content"><div class="post-content-inner"><p>Monday, Feb. 21 9 a.m. and 11 a.m. – The Department of Health told police employees at Ocean State...</p>
</div></div>
</article>
<article id="post-33926" class="et_pb_post clearfix et_pb_blog_item_0_3 post-33926 post type-post status-publish format-standard has-post-thumbnail hentry category-government category-police-fire tag-duke-street-fire tag-egfd tag-firefighters tag-local-iaff tag-nota tag-perry tag-union et-has-post-format-content et_post_format-et-post-format-standard">
<div class="et_pb_image_container"><a href="https://eastgreenwichnews.com/nota-takes-issue-w-firefighter-comments-following-friday-blaze/" class="entry-featured-image-url"><img loading="lazy" src="https://eastgreenwichnews.com/wp-content/uploads/2022/03/IMG_2518-400x250.jpeg" alt="Nota Takes Issue w/Firefighter Comments Following Friday Blaze " class="" srcset="https://eastgreenwichnews.com/wp-content/uploads/2022/03/IMG_2518-e1646523689656.jpeg 479w, https://eastgreenwichnews.com/wp-content/uploads/2022/03/IMG_2518-400x250.jpeg 480w " sizes="(max-width:479px) 479px, 100vw " width="400" height="250" /></a></div>
<h2 class="entry-title"><a href="https://eastgreenwichnews.com/nota-takes-issue-w-firefighter-comments-following-friday-blaze/">Nota Takes Issue w/Firefighter Comments Following Friday Blaze </a></h2>
<p class="post-meta"><span class="published">Mar 6, 2022</span></p><div class="post-content"><div class="post-content-inner"><p>Above: A mutual aid ladder truck fights the fire at 79 Duke St. Friday night. Photo by Tim Cure...</p>
</div></div>
</article>
</div>
</div>
</div>
</div>
</div><div class="et_pb_column et_pb_column_1_3 et_pb_column_1_tb_body  et_pb_css_mix_blend_mode_passthrough et-last-child">
<div class="et_pb_module et_pb_sidebar_0_tb_body et_pb_widget_area clearfix et_pb_widget_area_left et_pb_bg_layout_light et_pb_sidebar_no_border">
<div id="bs_zones-6" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="81620" keywords="not_home_page,not_landing_page,is_article_page,police-fire,police-log-catalytic-converters-disrespectful-straws,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-7" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="81621" keywords="not_home_page,not_landing_page,is_article_page,police-fire,police-log-catalytic-converters-disrespectful-straws,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-8" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="81622" keywords="not_home_page,not_landing_page,is_article_page,police-fire,police-log-catalytic-converters-disrespectful-straws,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-9" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="81623" keywords="not_home_page,not_landing_page,is_article_page,police-fire,police-log-catalytic-converters-disrespectful-straws,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="custom_html-3" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle">Newsletter Sign Up</h4><div class="textwidget custom-html-widget">
<link href="//cdn-images.mailchimp.com/embedcode/classic-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://facebook.us8.list-manage.com/subscribe/post?u=a70db183b5120074d9c9fff6a&amp;id=b19ddace9b" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<div class="indicates-required"><span class="asterisk">*</span> indicates required</div>
<div class="mc-field-group">
<label for="mce-EMAIL">Email Address <span class="asterisk">*</span>
</label>
<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">
</div>
<div class="mc-field-group">
<label for="mce-FNAME">First Name <span class="asterisk">*</span>
</label>
<input type="text" value="" name="FNAME" class="required" id="mce-FNAME">
</div>
<div class="mc-field-group">
<label for="mce-LNAME">Last Name <span class="asterisk">*</span>
</label>
<input type="text" value="" name="LNAME" class="required" id="mce-LNAME">
</div>
<div id="mce-responses" class="clear">
<div class="response" id="mce-error-response" style="display:none"></div>
<div class="response" id="mce-success-response" style="display:none"></div>
</div> 
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_a70db183b5120074d9c9fff6a_b19ddace9b" tabindex="-1" value=""></div>
<div class=“show”><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
<script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js' defer data-deferred="1"></script><script type='text/javascript' src="data:text/javascript;base64,KGZ1bmN0aW9uKCQpe3dpbmRvdy5mbmFtZXM9bmV3IEFycmF5KCk7d2luZG93LmZ0eXBlcz1uZXcgQXJyYXkoKTtmbmFtZXNbMF09J0VNQUlMJztmdHlwZXNbMF09J2VtYWlsJztmbmFtZXNbMV09J0ZOQU1FJztmdHlwZXNbMV09J3RleHQnO2ZuYW1lc1syXT0nTE5BTUUnO2Z0eXBlc1syXT0ndGV4dCc7Zm5hbWVzWzNdPSdNTUVSR0UzJztmdHlwZXNbM109J2FkZHJlc3MnfShqUXVlcnkpKTt2YXIgJG1jaj1qUXVlcnkubm9Db25mbGljdCghMCk=" defer></script>
</div></div> <div id="archives-4" class="et_pb_widget widget_archive"><h4 class="widgettitle">Archives</h4> <label class="screen-reader-text" for="archives-dropdown-4">Archives</label>
<select id="archives-dropdown-4" name="archive-dropdown">
<option value="">Select Month</option>
<option value='https://eastgreenwichnews.com/2022/03/'> March 2022 </option>
<option value='https://eastgreenwichnews.com/2022/02/'> February 2022 </option>
<option value='https://eastgreenwichnews.com/2022/01/'> January 2022 </option>
<option value='https://eastgreenwichnews.com/2021/12/'> December 2021 </option>
<option value='https://eastgreenwichnews.com/2021/11/'> November 2021 </option>
<option value='https://eastgreenwichnews.com/2021/10/'> October 2021 </option>
<option value='https://eastgreenwichnews.com/2021/09/'> September 2021 </option>
<option value='https://eastgreenwichnews.com/2021/08/'> August 2021 </option>
<option value='https://eastgreenwichnews.com/2021/07/'> July 2021 </option>
<option value='https://eastgreenwichnews.com/2021/06/'> June 2021 </option>
<option value='https://eastgreenwichnews.com/2021/05/'> May 2021 </option>
<option value='https://eastgreenwichnews.com/2021/04/'> April 2021 </option>
<option value='https://eastgreenwichnews.com/2021/03/'> March 2021 </option>
<option value='https://eastgreenwichnews.com/2021/02/'> February 2021 </option>
<option value='https://eastgreenwichnews.com/2021/01/'> January 2021 </option>
<option value='https://eastgreenwichnews.com/2020/12/'> December 2020 </option>
<option value='https://eastgreenwichnews.com/2020/11/'> November 2020 </option>
<option value='https://eastgreenwichnews.com/2020/10/'> October 2020 </option>
<option value='https://eastgreenwichnews.com/2020/09/'> September 2020 </option>
<option value='https://eastgreenwichnews.com/2020/08/'> August 2020 </option>
<option value='https://eastgreenwichnews.com/2020/07/'> July 2020 </option>
<option value='https://eastgreenwichnews.com/2020/06/'> June 2020 </option>
<option value='https://eastgreenwichnews.com/2020/05/'> May 2020 </option>
<option value='https://eastgreenwichnews.com/2020/04/'> April 2020 </option>
<option value='https://eastgreenwichnews.com/2020/03/'> March 2020 </option>
<option value='https://eastgreenwichnews.com/2020/02/'> February 2020 </option>
<option value='https://eastgreenwichnews.com/2020/01/'> January 2020 </option>
<option value='https://eastgreenwichnews.com/2019/12/'> December 2019 </option>
<option value='https://eastgreenwichnews.com/2019/11/'> November 2019 </option>
<option value='https://eastgreenwichnews.com/2019/10/'> October 2019 </option>
<option value='https://eastgreenwichnews.com/2019/09/'> September 2019 </option>
<option value='https://eastgreenwichnews.com/2019/08/'> August 2019 </option>
<option value='https://eastgreenwichnews.com/2019/07/'> July 2019 </option>
<option value='https://eastgreenwichnews.com/2019/06/'> June 2019 </option>
<option value='https://eastgreenwichnews.com/2019/05/'> May 2019 </option>
<option value='https://eastgreenwichnews.com/2019/04/'> April 2019 </option>
<option value='https://eastgreenwichnews.com/2019/03/'> March 2019 </option>
<option value='https://eastgreenwichnews.com/2019/02/'> February 2019 </option>
<option value='https://eastgreenwichnews.com/2019/01/'> January 2019 </option>
<option value='https://eastgreenwichnews.com/2018/12/'> December 2018 </option>
<option value='https://eastgreenwichnews.com/2018/11/'> November 2018 </option>
<option value='https://eastgreenwichnews.com/2018/10/'> October 2018 </option>
<option value='https://eastgreenwichnews.com/2018/09/'> September 2018 </option>
<option value='https://eastgreenwichnews.com/2018/08/'> August 2018 </option>
<option value='https://eastgreenwichnews.com/2018/07/'> July 2018 </option>
<option value='https://eastgreenwichnews.com/2018/06/'> June 2018 </option>
<option value='https://eastgreenwichnews.com/2018/05/'> May 2018 </option>
<option value='https://eastgreenwichnews.com/2018/04/'> April 2018 </option>
<option value='https://eastgreenwichnews.com/2018/03/'> March 2018 </option>
<option value='https://eastgreenwichnews.com/2018/02/'> February 2018 </option>
<option value='https://eastgreenwichnews.com/2018/01/'> January 2018 </option>
<option value='https://eastgreenwichnews.com/2017/12/'> December 2017 </option>
<option value='https://eastgreenwichnews.com/2017/11/'> November 2017 </option>
<option value='https://eastgreenwichnews.com/2017/10/'> October 2017 </option>
<option value='https://eastgreenwichnews.com/2017/09/'> September 2017 </option>
<option value='https://eastgreenwichnews.com/2017/08/'> August 2017 </option>
<option value='https://eastgreenwichnews.com/2017/07/'> July 2017 </option>
<option value='https://eastgreenwichnews.com/2015/04/'> April 2015 </option>
<option value='https://eastgreenwichnews.com/2015/03/'> March 2015 </option>
<option value='https://eastgreenwichnews.com/2015/02/'> February 2015 </option>
<option value='https://eastgreenwichnews.com/2015/01/'> January 2015 </option>
<option value='https://eastgreenwichnews.com/2014/12/'> December 2014 </option>
<option value='https://eastgreenwichnews.com/2014/11/'> November 2014 </option>
<option value='https://eastgreenwichnews.com/2014/10/'> October 2014 </option>
<option value='https://eastgreenwichnews.com/2014/09/'> September 2014 </option>
<option value='https://eastgreenwichnews.com/2014/08/'> August 2014 </option>
<option value='https://eastgreenwichnews.com/2014/07/'> July 2014 </option>
<option value='https://eastgreenwichnews.com/2014/06/'> June 2014 </option>
<option value='https://eastgreenwichnews.com/2014/05/'> May 2014 </option>
<option value='https://eastgreenwichnews.com/2014/04/'> April 2014 </option>
<option value='https://eastgreenwichnews.com/2014/03/'> March 2014 </option>
<option value='https://eastgreenwichnews.com/2014/02/'> February 2014 </option>
</select>
<script type="text/javascript" src="data:text/javascript;base64,KGZ1bmN0aW9uKCl7dmFyIGRyb3Bkb3duPWRvY3VtZW50LmdldEVsZW1lbnRCeUlkKCJhcmNoaXZlcy1kcm9wZG93bi00Iik7ZnVuY3Rpb24gb25TZWxlY3RDaGFuZ2UoKXtpZihkcm9wZG93bi5vcHRpb25zW2Ryb3Bkb3duLnNlbGVjdGVkSW5kZXhdLnZhbHVlIT09Jycpe2RvY3VtZW50LmxvY2F0aW9uLmhyZWY9dGhpcy5vcHRpb25zW3RoaXMuc2VsZWN0ZWRJbmRleF0udmFsdWV9fQpkcm9wZG93bi5vbmNoYW5nZT1vblNlbGVjdENoYW5nZX0pKCk=" defer></script>
</div> <div id="bs_zones-10" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="81624" keywords="not_home_page,not_landing_page,is_article_page,police-fire,police-log-catalytic-converters-disrespectful-straws,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="text-6" class="et_pb_widget widget_text"><h4 class="widgettitle">Latest Streaming</h4> <div class="textwidget"><div class="epyt-gallery" data-currpage="1" id="epyt_gallery_68258"><div class="epyt-video-wrapper"><iframe id="_ytid_75944" data-origwidth="1080" data-origheight="608" src="https://www.youtube.com/embed/eXKvDKWL9ZA?enablejsapi=1&autoplay=0&cc_load_policy=0&cc_lang_pref=&iv_load_policy=1&loop=0&modestbranding=1&rel=0&fs=1&playsinline=0&autohide=2&theme=dark&color=red&controls=1&" class="__youtube_prefs__  __youtube_prefs_widget__  no-lazyload" title="YouTube player" data-epytgalleryid="epyt_gallery_68258" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen data-no-lazy="1" data-skipgform_ajax_framebjll=""></iframe></div><div class="epyt-gallery-subscribe"><a target="_blank" class="epyt-gallery-subbutton" href="https://www.youtube.com/user/EastGreenwichNews?sub_confirmation=1" rel="noopener"><img alt="subscribe" src="https://eastgreenwichnews.com/wp-content/plugins/youtube-embed-plus/images/play-subscribe.png" />Subscribe</a></div><div class="epyt-gallery-list"><div class="epyt-pagination epyt-hide-pagination"><div tabindex="0" role="button" class="epyt-pagebutton epyt-prev  hide " data-playlistid="UUBGAZiIFsLWb7KG_c9T10bQ" data-pagesize="2" data-pagetoken="" data-epcolumns="2" data-showtitle="1" data-showpaging="0" data-autonext="0" data-thumbplay="1"><div class="epyt-arrow">&laquo;</div> <div>Prev</div></div><div class="epyt-pagenumbers "><div class="epyt-current">1</div><div class="epyt-pageseparator"> / </div><div class="epyt-totalpages">177</div></div><div tabindex="0" role="button" class="epyt-pagebutton epyt-next" data-playlistid="UUBGAZiIFsLWb7KG_c9T10bQ" data-pagesize="2" data-pagetoken="EAAaBlBUOkNBSQ" data-epcolumns="2" data-showtitle="1" data-showpaging="0" data-autonext="0" data-thumbplay="1"><div>Next</div> <div class="epyt-arrow">&raquo;</div></div><div class="epyt-loader"><img loading="lazy" alt="loading" width="16" height="11" src="https://eastgreenwichnews.com/wp-content/plugins/youtube-embed-plus/images/gallery-page-loader.gif"></div></div><div class="epyt-gallery-allthumbs  epyt-cols-2 "><div tabindex="0" role="button" data-videoid="eXKvDKWL9ZA" class="epyt-gallery-thumb"><div class="epyt-gallery-img-box"><div class="epyt-gallery-img" style="background-image: url(https://i.ytimg.com/vi/eXKvDKWL9ZA/hqdefault.jpg)"><div class="epyt-gallery-playhover"><img loading="lazy" alt="play" class="epyt-play-img" width="30" height="23" src="https://eastgreenwichnews.com/wp-content/plugins/youtube-embed-plus/images/playhover.png" data-no-lazy="1" data-skipgform_ajax_framebjll="" /><div class="epyt-gallery-playcrutch"></div></div></div></div><div class="epyt-gallery-title">32 Exchange Street Comes Down</div></div><div tabindex="0" role="button" data-videoid="jXpnYpoRXW8" class="epyt-gallery-thumb"><div class="epyt-gallery-img-box"><div class="epyt-gallery-img" style="background-image: url(https://i.ytimg.com/vi/jXpnYpoRXW8/hqdefault.jpg)"><div class="epyt-gallery-playhover"><img loading="lazy" alt="play" class="epyt-play-img" width="30" height="23" src="https://eastgreenwichnews.com/wp-content/plugins/youtube-embed-plus/images/playhover.png" data-no-lazy="1" data-skipgform_ajax_framebjll="" /><div class="epyt-gallery-playcrutch"></div></div></div></div><div class="epyt-gallery-title">Snow Be Gone</div></div><div class="epyt-gallery-rowbreak"></div><div class="epyt-gallery-clear"></div></div><div class="epyt-pagination epyt-hide-pagination"><div tabindex="0" role="button" class="epyt-pagebutton epyt-prev  hide " data-playlistid="UUBGAZiIFsLWb7KG_c9T10bQ" data-pagesize="2" data-pagetoken="" data-epcolumns="2" data-showtitle="1" data-showpaging="0" data-autonext="0" data-thumbplay="1"><div class="epyt-arrow">&laquo;</div> <div>Prev</div></div><div class="epyt-pagenumbers "><div class="epyt-current">1</div><div class="epyt-pageseparator"> / </div><div class="epyt-totalpages">177</div></div><div tabindex="0" role="button" class="epyt-pagebutton epyt-next" data-playlistid="UUBGAZiIFsLWb7KG_c9T10bQ" data-pagesize="2" data-pagetoken="EAAaBlBUOkNBSQ" data-epcolumns="2" data-showtitle="1" data-showpaging="0" data-autonext="0" data-thumbplay="1"><div>Next</div> <div class="epyt-arrow">&raquo;</div></div><div class="epyt-loader"><img loading="lazy" alt="loading" width="16" height="11" src="https://eastgreenwichnews.com/wp-content/plugins/youtube-embed-plus/images/gallery-page-loader.gif"></div></div></div></div>
<p>&nbsp;</p>
</div>
</div> <div id="bs_zones-15" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="81624" keywords="not_home_page,not_landing_page,is_article_page,police-fire,police-log-catalytic-converters-disrespectful-straws,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> 
</div>
</div>
</div>
</div> </div>
</div>
<footer class="et-l et-l--footer">
<div class="et_builder_inner_content et_pb_gutters3"><div class="et_pb_section et_pb_section_0_tb_footer et_pb_with_background et_section_regular">
<div class="et_pb_row et_pb_row_0_tb_footer">
<div class="et_pb_column et_pb_column_1_3 et_pb_column_0_tb_footer  et_pb_css_mix_blend_mode_passthrough">
<div class="et_pb_module et_pb_image et_pb_image_0_tb_footer">
<span class="et_pb_image_wrap "><img loading="lazy" width="1228" height="296" src="https://eastgreenwichnews.com/wp-content/uploads/2020/09/EGNews_Logo_Final_white.png" alt="" title="EGNews_Logo_Final_white" srcset="https://eastgreenwichnews.com/wp-content/uploads/2020/09/EGNews_Logo_Final_white.png 1228w, https://eastgreenwichnews.com/wp-content/uploads/2020/09/EGNews_Logo_Final_white-768x185.png 768w, https://eastgreenwichnews.com/wp-content/uploads/2020/09/EGNews_Logo_Final_white-1080x260.png 1080w" sizes="(max-width: 1228px) 100vw, 1228px" class="wp-image-23913" /></span>
</div><div class="et_pb_module et_pb_text et_pb_text_0_tb_footer  et_pb_text_align_left et_pb_bg_layout_dark">
<div class="et_pb_text_inner">18 Prospect St.<br />
East Greenwich, RI 02818<br />
<a href="tel:401-749-3115">401.749.3115</a></p>
<p><a href="/cdn-cgi/l/email-protection#31545558455e437154504245564354545f465852595f5446421f525e5c"><span class="__cf_email__" data-cfemail="3d58595449524f7d585c4e495a4f5858534a545e5553584a4e135e5250">[email&#160;protected]</span></a></div>
</div><div class="et_pb_module et_pb_text et_pb_text_1_tb_footer  et_pb_text_align_left et_pb_bg_layout_dark">
<div class="et_pb_text_inner"><h4 class="widgettitle">Follow Us</h4></div>
</div><ul class="et_pb_module et_pb_social_media_follow et_pb_social_media_follow_0_tb_footer clearfix  et_pb_bg_layout_light">
<li class='et_pb_social_media_follow_network_0_tb_footer et_pb_social_icon et_pb_social_network_link  et-social-facebook'><a href='https://www.facebook.com/eastgreenwichnews/' class='icon et_pb_with_border' title='Follow on Facebook' target="_blank"><span class='et_pb_social_media_follow_network_name' aria-hidden='true'>Follow</span></a></li><li class='et_pb_social_media_follow_network_1_tb_footer et_pb_social_icon et_pb_social_network_link  et-social-twitter'><a href='https://twitter.com/egreenwichnews?lang=en' class='icon et_pb_with_border' title='Follow on Twitter' target="_blank"><span class='et_pb_social_media_follow_network_name' aria-hidden='true'>Follow</span></a></li><li class='et_pb_social_media_follow_network_2_tb_footer et_pb_social_icon et_pb_social_network_link  et-social-instagram'><a href='https://www.instagram.com/eastgreenwichnews/' class='icon et_pb_with_border' title='Follow on Instagram' target="_blank"><span class='et_pb_social_media_follow_network_name' aria-hidden='true'>Follow</span></a></li><li class='et_pb_social_media_follow_network_3_tb_footer et_pb_social_icon et_pb_social_network_link  et-social-linkedin'><a href='https://www.linkedin.com/company/eastgreenwichnews/' class='icon et_pb_with_border' title='Follow on LinkedIn' target="_blank"><span class='et_pb_social_media_follow_network_name' aria-hidden='true'>Follow</span></a></li><li class='et_pb_social_media_follow_network_4_tb_footer et_pb_social_icon et_pb_social_network_link  et-social-youtube'><a href='https://www.youtube.com/user/EastGreenwichNews' class='icon et_pb_with_border' title='Follow on Youtube' target="_blank"><span class='et_pb_social_media_follow_network_name' aria-hidden='true'>Follow</span></a></li>
</ul>
</div><div class="et_pb_column et_pb_column_1_3 et_pb_column_1_tb_footer  et_pb_css_mix_blend_mode_passthrough">
<div class="et_pb_module et_pb_text et_pb_text_2_tb_footer  et_pb_text_align_left et_pb_bg_layout_light">
<div class="et_pb_text_inner"><p><span>East Greenwich News is committed to building an informed community through thoughtful, relevant and objective reporting about the people, places and events in East Greenwich, Rhode Island. </span>We are a 501(c)(3) nonprofit and <span>a free news source, funded by the community. Donations help us keep bringing you the local news you’ve been counting on.</span></p></div>
</div><div class="et_pb_button_module_wrapper et_pb_button_0_tb_footer_wrapper  et_pb_module ">
<a class="et_pb_button et_pb_button_0_tb_footer et_pb_bg_layout_dark" href="https://www.paypal.com/donate/?cmd=_s-xclick&#038;hosted_button_id=RYEHTGQBSJEWW&#038;source=url" target="_blank">DONATE TODAY</a>
</div><div class="et_pb_module et_pb_text et_pb_text_3_tb_footer  et_pb_text_align_left et_pb_bg_layout_light">
<div class="et_pb_text_inner"><p style="color: #ffffff;"><strong>Proud member of</strong></p>
<p style="color: #ffffff;"><strong><img loading="lazy" src="https://eastgreenwichnews.com/wp-content/uploads/2020/09/INN-Logo-Primary-White-480x160-1.png" width="212" height="75" alt="" class="wp-image-23761 alignnone size-full" /><img loading="lazy" src="https://eastgreenwichnews.com/wp-content/uploads/2021/11/lion-hero_white.png" width="109" height="54" alt="" class="wp-image-32267 alignnone size-full" /></strong><strong><br /></strong><span style="color: #333333;"> </span></p></div>
</div>
</div><div class="et_pb_column et_pb_column_1_3 et_pb_column_2_tb_footer  et_pb_css_mix_blend_mode_passthrough et-last-child">
<div class="et_pb_module et_pb_code et_pb_code_0_tb_footer">
<div class="et_pb_code_inner">
<link href="//cdn-images.mailchimp.com/embedcode/classic-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://facebook.us8.list-manage.com/subscribe/post?u=a70db183b5120074d9c9fff6a&#038;id=b19ddace9b" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<h2>Newsletter Sign Up</h2>
<div class="indicates-required"><span class="asterisk">*</span> indicates required</div>
<div class="mc-field-group">
<label for="mce-EMAIL">Email Address <span class="asterisk">*</span>
</label>
<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">
</div>
<div class="mc-field-group">
<label for="mce-FNAME">First Name <span class="asterisk">*</span>
</label>
<input type="text" value="" name="FNAME" class="required" id="mce-FNAME">
</div>
<div class="mc-field-group">
<label for="mce-LNAME">Last Name <span class="asterisk">*</span>
</label>
<input type="text" value="" name="LNAME" class="required" id="mce-LNAME">
</div>
<div id="mce-responses" class="clear">
<div class="response" id="mce-error-response" style="display:none"></div>
<div class="response" id="mce-success-response" style="display:none"></div>
</div> 
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_a70db183b5120074d9c9fff6a_b19ddace9b" tabindex="-1" value=""></div>
<div class=“show”><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js' defer data-deferred="1"></script><script type='text/javascript' src="data:text/javascript;base64,KGZ1bmN0aW9uKCQpe3dpbmRvdy5mbmFtZXM9bmV3IEFycmF5KCk7d2luZG93LmZ0eXBlcz1uZXcgQXJyYXkoKTtmbmFtZXNbMF09J0VNQUlMJztmdHlwZXNbMF09J2VtYWlsJztmbmFtZXNbMV09J0ZOQU1FJztmdHlwZXNbMV09J3RleHQnO2ZuYW1lc1syXT0nTE5BTUUnO2Z0eXBlc1syXT0ndGV4dCc7Zm5hbWVzWzNdPSdNTUVSR0UzJztmdHlwZXNbM109J2FkZHJlc3MnfShqUXVlcnkpKTt2YXIgJG1jaj1qUXVlcnkubm9Db25mbGljdCghMCk=" defer></script>
</div>
</div>
</div>
</div><div class="et_pb_row et_pb_row_1_tb_footer">
<div class="et_pb_column et_pb_column_4_4 et_pb_column_3_tb_footer  et_pb_css_mix_blend_mode_passthrough et-last-child">
<div class="et_pb_module et_pb_text et_pb_text_4_tb_footer  et_pb_text_align_left et_pb_bg_layout_light">
<div class="et_pb_text_inner"><p>© East Greenwich News. All rights reserved.</p></div>
</div>
</div>
</div>
</div> </div>
</footer>
</div>
</div> 
<span title="Back To Top" id="back_to_top"></span>
<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','police-fire','police-log-catalytic-converters-disrespectful-straws','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["police-fire","police-log-catalytic-converters-disrespectful-straws","post"],"url":"police-log-catalytic-converters-disrespectful-straws"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.loadNetworkJS(5949);
 });</script><style id="et-builder-googlefonts-inline">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</style><noscript><img height="1" width="1" style="display: none;" src="https://www.facebook.com/tr?id=952258548903681&ev=PageView&noscript=1&cd%5Bpost_category%5D=Police+%26+Fire&cd%5Bpage_title%5D=Police+Log%3A%C2%A0Catalytic+Converters%2C+%27Disrespectful%27+Straws&cd%5Bpost_type%5D=post&cd%5Bpost_id%5D=34121&cd%5Bplugin%5D=PixelYourSite&cd%5Buser_role%5D=guest&cd%5Bevent_url%5D=eastgreenwichnews.com%2Fpolice-log-catalytic-converters-disrespectful-straws%2F" alt="facebook_pixel"></noscript>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-includes/js/jquery/ui/core.min.js?ver=1.13.1' id='jquery-ui-core-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.13.1' id='jquery-ui-mouse-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.13.1' id='jquery-ui-draggable-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.13.1' id='jquery-ui-slider-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2' id='jquery-touch-punch-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-admin/js/iris.min.js?ver=5.9.2' id='iris-js' defer data-deferred="1"></script>
<script type='text/javascript' id='wp-color-picker-js-extra' src="data:text/javascript;base64,dmFyIHdwQ29sb3JQaWNrZXJMMTBuPXsiY2xlYXIiOiJDbGVhciIsImRlZmF1bHRTdHJpbmciOiJEZWZhdWx0IiwicGljayI6IlNlbGVjdCBDb2xvciJ9O3ZhciB3cENvbG9yUGlja2VyTDEwbj17ImNsZWFyIjoiQ2xlYXIiLCJkZWZhdWx0U3RyaW5nIjoiRGVmYXVsdCIsInBpY2siOiJTZWxlY3QgQ29sb3IiLCJjdXJyZW50IjoiQ3VycmVudCBDb2xvciJ9" defer></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-admin/js/color-picker.min.js?ver=5.9.2' id='wp-color-picker-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b' id='jquery-masonry-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-js/no-script.js?ver=5.9.2' id='directorist-no-script-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-js/openstreet-map/openstreetlayers.js?ver=5.9.2' id='directorist-openstreet-layers-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-js/openstreet-map/unpkg-min.js?ver=5.9.2' id='directorist-openstreet-unpkg-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-js/openstreet-map/unpkg-index.js?ver=5.9.2' id='directorist-openstreet-unpkg-index-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-js/openstreet-map/unpkg-libs.js?ver=5.9.2' id='directorist-openstreet-unpkg-libs-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-js/openstreet-map/leaflet-versions.js?ver=5.9.2' id='directorist-openstreet-leaflet-versions-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-js/openstreet-map/leaflet.markercluster-versions.js?ver=5.9.2' id='directorist-openstreet-leaflet-markercluster-versions-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-js/openstreet-map/libs-setup.js?ver=5.9.2' id='directorist-openstreet-libs-setup-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-js/openstreet-map/openlayers/OpenLayers.js?ver=5.9.2' id='directorist-openstreet-open-layers-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-js/openstreet-map/openlayers4jgsi/Crosshairs.js?ver=5.9.2' id='directorist-openstreet-crosshairs-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-js/select2.min.js?ver=7.1.2' id='directorist-select2-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-js/sweetalert.min.js?ver=7.1.2' id='directorist-sweetalert-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-js/popper.min.js?ver=7.1.2' id='directorist-popper-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-js/tooltip.js?ver=7.1.2' id='directorist-tooltip-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-js/ez-media-uploader.js?ver=7.1.2' id='directorist-ez-media-uploader-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-js/jquery.barrating.min.js?ver=7.1.2' id='directorist-jquery-barrating-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-js/slick.min.js?ver=7.1.2' id='directorist-slick-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/vendor-js/plasma-slider.js?ver=7.1.2' id='directorist-plasma-slider-js' defer data-deferred="1"></script>
<script type='text/javascript' id='directorist-global-script-js-extra' src="data:text/javascript;base64,dmFyIGRpcmVjdG9yaXN0X29wdGlvbnM9eyJzY3JpcHRfZGVidWdnaW5nIjoiMSJ9" defer></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/js/global-main.min.js?ver=7.1.2' id='directorist-global-script-js' defer data-deferred="1"></script>
<script type='text/javascript' id='directorist-main-script-js-extra' src="data:text/javascript;base64,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" defer></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/js/public-main.min.js?ver=7.1.2' id='directorist-main-script-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/directorist/assets/js/public-atmodal.min.js?ver=7.1.2' id='directorist-atmodal-js' defer data-deferred="1"></script>
<script type='text/javascript' id='give-paypal-commerce-js-js-extra' src="data:text/javascript;base64,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" defer></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/give/assets/dist/js/paypal-commerce.js?ver=2.19.5' id='give-paypal-commerce-js-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9' id='regenerator-runtime-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-includes/js/dist/hooks.min.js?ver=1e58c8c5a32b2e97491080c5b10dc71c' id='wp-hooks-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-includes/js/dist/i18n.min.js?ver=30fcecb428a0e8383d3776bcdd3a7834' id='wp-i18n-js' defer data-deferred="1"></script>
<script type='text/javascript' id='wp-i18n-js-after' src="data:text/javascript;base64,d3AuaTE4bi5zZXRMb2NhbGVEYXRhKHsndGV4dCBkaXJlY3Rpb25cdTAwMDRsdHInOlsnbHRyJ119KQ==" defer></script>
<script type='text/javascript' id='give-donation-summary-script-frontend-js-extra' src="data:text/javascript;base64,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" defer></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/give/assets/dist/js/give-donation-summary.js?ver=2.19.5' id='give-donation-summary-script-frontend-js' defer data-deferred="1"></script>
<script type='text/javascript' id='extra-scripts-js-extra' src="data:text/javascript;base64,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" defer></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/themes/Extra/scripts/scripts.min.js?ver=4.15.0' id='extra-scripts-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-includes/js/comment-reply.min.js?ver=5.9.2' id='comment-reply-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/themes/Extra/includes/builder/feature/dynamic-assets/assets/js/jquery.fitvids.js?ver=4.15.0' id='fitvids-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/themes/Extra/includes/builder/feature/dynamic-assets/assets/js/easypiechart.js?ver=4.15.0' id='easypiechart-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/themes/Extra/includes/builder/feature/dynamic-assets/assets/js/salvattore.js?ver=4.15.0' id='salvattore-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/themes/Extra/core/admin/js/common.js?ver=4.15.0' id='et-core-common-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=14.1' id='__ytprefsfitvids__-js' defer data-deferred="1"></script>
<script type='text/javascript' id='mediaelement-core-js-before' src="data:text/javascript;base64,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" defer></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.16' id='mediaelement-core-js' defer data-deferred="1"></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=5.9.2' id='mediaelement-migrate-js' defer data-deferred="1"></script>
<script type='text/javascript' id='mediaelement-js-extra' src="data:text/javascript;base64,dmFyIF93cG1lanNTZXR0aW5ncz17InBsdWdpblBhdGgiOiJcL3dwLWluY2x1ZGVzXC9qc1wvbWVkaWFlbGVtZW50XC8iLCJjbGFzc1ByZWZpeCI6Im1lanMtIiwic3RyZXRjaGluZyI6InJlc3BvbnNpdmUifQ==" defer></script>
<script type='text/javascript' src='https://eastgreenwichnews.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=5.9.2' id='wp-mediaelement-js' defer data-deferred="1"></script>
<style id="et-builder-module-design-tb-22272-tb-21502-34121-cached-inline-styles">.et_pb_section_0_tb_body{padding-top:41px;padding-bottom:0px}.et_pb_row_0_tb_body.et_pb_row{padding-top:10px!important;padding-bottom:6px!important;padding-top:10px;padding-bottom:6px}.et_pb_row_0_tb_body{max-width:1600px}.et_pb_post_title_0_tb_body .et_pb_title_container h1.entry-title,.et_pb_post_title_0_tb_body .et_pb_title_container h2.entry-title,.et_pb_post_title_0_tb_body .et_pb_title_container h3.entry-title,.et_pb_post_title_0_tb_body .et_pb_title_container h4.entry-title,.et_pb_post_title_0_tb_body .et_pb_title_container h5.entry-title,.et_pb_post_title_0_tb_body .et_pb_title_container h6.entry-title{line-height:1.2em}.et_pb_post_title_0_tb_body .et_pb_title_container .et_pb_title_meta_container,.et_pb_post_title_0_tb_body .et_pb_title_container .et_pb_title_meta_container a{font-size:13px}.et_pb_post_title_0_tb_body .et_pb_title_featured_container img{height:auto;max-height:none}.et_pb_post_title_0_tb_body .et_pb_title_featured_container{width:100%;max-width:none;text-align:left;margin:auto auto auto 0}.et_pb_post_title_0_tb_body .et_pb_image_wrap{width:auto}.et_pb_divider_0_tb_body{margin-bottom:-12px!important}.et_pb_divider_0_tb_body:before{border-top-color:#999999;border-top-width:4px}.et_pb_text_0_tb_body.et_pb_text{color:#828282!important}.et_pb_text_0_tb_body{font-size:13px;margin-bottom:13px!important}.et_pb_button_0_tb_body_wrapper{margin-bottom:22px!important}.et_pb_button_0_tb_body,.et_pb_button_0_tb_body:after{transition:all 300ms ease 0ms}.et_pb_divider_1_tb_body,.et_pb_divider_2_tb_body{padding-bottom:23px;margin-bottom:-12px!important}.et_pb_divider_1_tb_body:before,.et_pb_divider_2_tb_body:before{border-top-color:#999999;border-top-width:4px;width:auto;top:0px;right:0px;left:0px}.et_pb_text_1_tb_body{margin-bottom:3px!important}.et_pb_sidebar_0_tb_body.et_pb_widget_area h3:first-of-type,.et_pb_sidebar_0_tb_body.et_pb_widget_area h4:first-of-type,.et_pb_sidebar_0_tb_body.et_pb_widget_area h5:first-of-type,.et_pb_sidebar_0_tb_body.et_pb_widget_area h6:first-of-type,.et_pb_sidebar_0_tb_body.et_pb_widget_area h2:first-of-type,.et_pb_sidebar_0_tb_body.et_pb_widget_area h1:first-of-type,.et_pb_sidebar_0_tb_body.et_pb_widget_area .widget-title,.et_pb_sidebar_0_tb_body.et_pb_widget_area .widgettitle{font-weight:600;font-size:16px;color:#FFFFFF!important}@media only screen and (max-width:980px){.et_pb_post_title_0_tb_body .et_pb_title_featured_container{text-align:none}}@media only screen and (max-width:767px){.et_pb_post_title_0_tb_body .et_pb_title_featured_container{text-align:none}}</style><style id="et-builder-module-design-tb-22272-tb-21502-deferred-34121-cached-inline-styles">.et_pb_section_0_tb_footer{padding-bottom:14px}.et_pb_section_0_tb_footer.et_pb_section{background-color:#2d2d2d!important}.et_pb_row_0_tb_footer,.et_pb_row_1_tb_footer{max-width:2560px}.et_pb_image_0_tb_footer{margin-bottom:13px!important;width:75%;text-align:left;margin-left:0}.et_pb_text_1_tb_footer.et_pb_text,.et_pb_text_1_tb_footer h1,.et_pb_text_1_tb_footer h2,.et_pb_text_1_tb_footer h3,.et_pb_text_1_tb_footer h4,.et_pb_text_1_tb_footer h5,.et_pb_text_1_tb_footer h6,.et_pb_text_2_tb_footer.et_pb_text{color:#FFFFFF!important}.et_pb_text_1_tb_footer.et_pb_text a{color:#629cd6!important}.et_pb_text_1_tb_footer{margin-bottom:1px!important}.et_pb_button_0_tb_footer_wrapper{margin-bottom:79px!important}body #page-container .et_pb_section .et_pb_button_0_tb_footer{letter-spacing:1px;font-size:16px}body #page-container .et_pb_section .et_pb_button_0_tb_footer,body #page-container .et_pb_section .et_pb_button_0_tb_footer:hover{padding:0.3em 1em!important}body #page-container .et_pb_section .et_pb_button_0_tb_footer:before,body #page-container .et_pb_section .et_pb_button_0_tb_footer:after{display:none!important}.et_pb_button_0_tb_footer,.et_pb_button_0_tb_footer:after{transition:all 300ms ease 0ms}.et_pb_row_1_tb_footer.et_pb_row{padding-top:0px!important;padding-top:0px}.et_pb_text_4_tb_footer.et_pb_text{color:#c4c4c4!important}.et_pb_text_4_tb_footer{font-size:12px}.et_pb_social_media_follow_network_0_tb_footer a.icon{background-color:#3b5998!important}.et_pb_social_media_follow_network_1_tb_footer a.icon{background-color:#00aced!important}.et_pb_social_media_follow_network_2_tb_footer a.icon{background-color:#ea2c59!important}.et_pb_social_media_follow_network_3_tb_footer a.icon{background-color:#007bb6!important}.et_pb_social_media_follow_network_4_tb_footer a.icon{background-color:#a82400!important}@media only screen and (max-width:980px){.et_pb_image_0_tb_footer .et_pb_image_wrap img{width:auto}}@media only screen and (max-width:767px){.et_pb_image_0_tb_footer .et_pb_image_wrap img{width:auto}}</style><script src='https://stats.wp.com/e-202212.js' defer></script>
<script src="data:text/javascript;base64,X3N0cT13aW5kb3cuX3N0cXx8W107X3N0cS5wdXNoKFsndmlldycse3Y6J2V4dCcsajonMToxMC43JyxibG9nOicyMDE5NzU5NTYnLHBvc3Q6JzM0MTIxJyx0ejonLTQnLHNydjonZWFzdGdyZWVud2ljaG5ld3MuY29tJ31dKTtfc3RxLnB1c2goWydjbGlja1RyYWNrZXJJbml0JywnMjAxOTc1OTU2JywnMzQxMjEnXSk=" defer></script>
<script data-no-optimize="1">var litespeed_vary=document.cookie.replace(/(?:(?:^|.*;\s*)_lscache_vary\s*\=\s*([^;]*).*$)|^.*$/,"");litespeed_vary||fetch("/wp-content/plugins/litespeed-cache/guest.vary.php",{method:"POST",cache:"no-cache",redirect:"follow"}).then(e=>e.json()).then(e=>{console.log(e),e.hasOwnProperty("reload")&&"yes"==e.reload&&(sessionStorage.setItem("litespeed_docref",document.referrer),window.location.reload(!0))});</script><script type="text/javascript">(function(){window['__CF$cv$params']={r:'6ef53f694c108005',m:'o2ofl8JJ4Bs11L2Nmq44iP8Db.0ULDNeG2NensVmPOo-1647850610-0-AThN7ZVtfmV8NSCLHS+OCkLSJC28Rhv+gRBHETidoUP3Fb45y74WqK2bL/hik03ExoePnI2qFsdPGfw5PDE+27H44iF4WSxthqR/L5AmMDH7QZVLZnnvcj9TXO75PYBX679F+wYcfc4/KfJCQ5WD0HGAZ1AN5ogDBdO01NhOk4hqI8slkdXe68WjJdznHoVbhw==',s:[0x2bfad6fa7d,0xd6f00681da],}})();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"6ef53f694c108005","token":"3e8c239c750a4ee09f7519ce2c753334","version":"2021.12.0","si":100}' crossorigin="anonymous"></script>
</body>
</html>

